Lucene search
+L

CVE-2025-62372 vLLM vulnerable to DoS with incorrect shape of multimodal embedding inputs

🗓️ 21 Nov 2025 01:22:37Reported by GitHub_MType 
cvelist
 cvelist
🔗 www.cve.org👁 43 Views

vLLM can cause denial of service when multimodal inputs have correct ndim but incorrect shape; affected versions before 0.11.1, fixed in 0.11.1.

Related
Affected
Refs
ReporterTitlePublishedViews
Family
bdu_fstec
BDU FSTEC
vLLM Unverified Array Indexing DoS
26 Nov 202500:00
–bdu_fstec
cgr
Chainguard
CVE-2025-62372 vulnerabilities
1 Dec 202519:44
–cgr
circl
Circl
CVE-2025-62372
21 Nov 202503:22
–circl
cnnvd
CNNVD
vLLM input validation vulnerability
21 Nov 202500:00
–cnnvd
cve
CVE
CVE-2025-62372
21 Nov 202501:22
–cve
euvd
EUVD
EUVD-2025-198357
21 Nov 202501:22
–euvd
github
Github Security Blog
vLLM vulnerable to DoS with incorrect shape of multimodal embedding inputs
20 Nov 202521:23
–github
mend
Mend
CVE-2025-62372
21 Nov 202501:22
–mend
nvd
NVD
CVE-2025-62372
21 Nov 202502:15
–nvd
osv_cga
osv_cga
CGA-7JM9-GQGH-846V
22 Nov 202522:54
–osv_cga
Rows per page
[
  {
    "vendor": "vllm-project",
    "product": "vllm",
    "versions": [
      {
        "version": ">= 0.5.5, < 0.11.1",
        "status": "affected"
      }
    ]
  }
]

Data

Build on a solid foundation with Vulners data

We provide the essential building blocks for cybersecurity solutions with comprehensive, structured, and constantly updated vulnerability and exploits data

Api

Power your application with Vulners API

The Vulners REST API offers reliable, high-performance access to vulnerability intelligence, with 99.9% SLA uptime and CDN-backed data delivery for seamless global access

App

Assess and manage vulnerabilities with Vulners tools

Built on top of Vulners' database and SDK, end-user solutions give security professionals and developers lightweight and powerful tools for vulnerability remediation