Lucene search

K
cvelistHiddenLayerCVELIST:CVE-2024-37064
HistoryJun 04, 2024 - 12:03 p.m.

CVE-2024-37064

2024-06-0412:03:07
CWE-502
HiddenLayer
www.cve.org
3
deserialization
ydata
profiling
vulnerability
version 3.7.0
arbitrary code

CVSS3

7.8

Attack Vector

LOCAL

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

REQUIRED

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

EPSS

0

Percentile

9.0%

Deseriliazation of untrusted data can occur in versions 3.7.0 or newer of Ydata’s ydata-profiling open-source library, enabling a maliciously crafted dataset to run arbitrary code on an end user’s system when loaded.

CNA Affected

[
  {
    "defaultStatus": "unaffected",
    "packageName": "ydata-profiling",
    "product": "ydata-profiling",
    "repo": "https://github.com/ydataai/ydata-profiling",
    "vendor": "YdataAI",
    "versions": [
      {
        "lessThanOrEqual": "*",
        "status": "affected",
        "version": "3.7.0",
        "versionType": "semver"
      }
    ]
  }
]

CVSS3

7.8

Attack Vector

LOCAL

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

REQUIRED

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

EPSS

0

Percentile

9.0%

Related for CVELIST:CVE-2024-37064