Lucene search

K
cvelistVulnCheckCVELIST:CVE-2024-23688
HistoryJan 19, 2024 - 9:26 p.m.

CVE-2024-23688 Consensys Discovery Nonce Reuse

2024-01-1921:26:35
CWE-323
VulnCheck
www.cve.org
consensys
discovery
nonce reuse
aes/gcm
vulnerability

5.6 Medium

AI Score

Confidence

High

0.001 Low

EPSS

Percentile

20.5%

Consensys Discovery versions less than 0.4.5 uses the same AES/GCM nonce for the entire session. which should ideally be unique for every message. The node’s private key isn’t compromised, only the session key generated for specific peer communication is exposed.

CNA Affected

[
  {
    "collectionURL": "https://repo.maven.apache.org/maven2",
    "defaultStatus": "unaffected",
    "packageName": "tech.pegasys.discovery:discovery",
    "versions": [
      {
        "lessThan": "0.4.5",
        "status": "affected",
        "version": "0",
        "versionType": "maven"
      }
    ]
  }
]

5.6 Medium

AI Score

Confidence

High

0.001 Low

EPSS

Percentile

20.5%

Related for CVELIST:CVE-2024-23688