Lucene search

K
cvelistWordfenceCVELIST:CVE-2023-4247
HistoryJan 11, 2024 - 8:33 a.m.

CVE-2023-4247

2024-01-1108:33:05
Wordfence
www.cve.org
givewp
wordpress
cross-site request forgery
vulnerable
nonce validation
sendwp plugin
unauthenticated attackers
deactivate
forged request
site administrator

5.4 Medium

CVSS3

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

REQUIRED

Scope

UNCHANGED

Confidentiality Impact

NONE

Integrity Impact

LOW

Availability Impact

LOW

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:L

5.4 Medium

AI Score

Confidence

High

0.001 Low

EPSS

Percentile

28.5%

The GiveWP plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 2.33.3. This is due to missing or incorrect nonce validation on the give_sendwp_disconnect function. This makes it possible for unauthenticated attackers to deactivate the SendWP plugin via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

CNA Affected

[
  {
    "vendor": "webdevmattcrom",
    "product": "GiveWP – Donation Plugin and Fundraising Platform",
    "versions": [
      {
        "version": "*",
        "status": "affected",
        "lessThanOrEqual": "2.33.3",
        "versionType": "semver"
      }
    ],
    "defaultStatus": "unaffected"
  }
]

5.4 Medium

CVSS3

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

REQUIRED

Scope

UNCHANGED

Confidentiality Impact

NONE

Integrity Impact

LOW

Availability Impact

LOW

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:L

5.4 Medium

AI Score

Confidence

High

0.001 Low

EPSS

Percentile

28.5%

Related for CVELIST:CVE-2023-4247