Lucene search

K
cvelistZdiCVELIST:CVE-2023-42120
HistoryMay 03, 2024 - 2:13 a.m.

CVE-2023-42120 Control Web Panel dns_zone_editor Command Injection Remote Code Execution Vulnerability

2024-05-0302:13:27
CWE-78
zdi
www.cve.org
control web panel
dns_zone_editor
command injection
remote code execution
vulnerability
authentication
flaw
code execution
root
zdi-can-20581

8.8 High

CVSS3

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

LOW

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

0.001 Low

EPSS

Percentile

30.7%

Control Web Panel dns_zone_editor Command Injection Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of Control Web Panel. Authentication is required to exploit this vulnerability.

The specific flaw exists within the dns_zone_editor module. The issue results from the lack of proper validation of a user-supplied string before using it to execute a system call. An attacker can leverage this vulnerability to execute code in the context of root. Was ZDI-CAN-20581.

CNA Affected

[
  {
    "vendor": "Control Web Panel",
    "product": "Control Web Panel",
    "versions": [
      {
        "version": "0.9.8.1152",
        "status": "affected"
      }
    ],
    "defaultStatus": "unknown"
  }
]

8.8 High

CVSS3

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

LOW

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

0.001 Low

EPSS

Percentile

30.7%

Related for CVELIST:CVE-2023-42120