Lucene search

K
cvelistGitHub_MCVELIST:CVE-2023-41042
HistorySep 15, 2023 - 7:26 p.m.

CVE-2023-41042 Discourse DoS via remote theme assets

2023-09-1519:26:43
CWE-770
GitHub_M
www.cve.org
cve-2023-41042
discourse
dos
remote theme
memory loading
version 3.1.1
version 3.2.0.beta1

CVSS3

4.9

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

HIGH

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

NONE

Integrity Impact

NONE

Availability Impact

HIGH

CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H

EPSS

0

Percentile

15.6%

Discourse is an open-source discussion platform. Prior to version 3.1.1 of the stable branch and version 3.2.0.beta1 of the beta and tests-passed branches, importing a remote theme loads their assets into memory without enforcing limits for file size or number of files. The issue is patched in version 3.1.1 of the stable branch and version 3.2.0.beta1 of the beta and tests-passed branches. There are no known workarounds.

CNA Affected

[
  {
    "vendor": "discourse",
    "product": "discourse",
    "versions": [
      {
        "version": "stable < 3.1.1",
        "status": "affected"
      },
      {
        "version": "beta < 3.2.0.beta1",
        "status": "affected"
      },
      {
        "version": "tests-passed < 3.2.0.beta1",
        "status": "affected"
      }
    ]
  }
]

CVSS3

4.9

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

HIGH

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

NONE

Integrity Impact

NONE

Availability Impact

HIGH

CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H

EPSS

0

Percentile

15.6%

Related for CVELIST:CVE-2023-41042