Lucene search

K
cvelistApacheCVELIST:CVE-2023-40037
HistoryAug 18, 2023 - 9:54 p.m.

CVE-2023-40037 Apache NiFi: Incomplete Validation of JDBC and JNDI Connection URLs

2023-08-1821:54:52
CWE-184
apache
www.cve.org
apache nifi
jdbc
jndi
connection url
validation
security vulnerability
upgrade

AI Score

6.6

Confidence

High

EPSS

0.001

Percentile

42.8%

Apache NiFi 1.21.0 through 1.23.0 support JDBC and JNDI JMS access in several Processors and Controller Services with connection URL validation that does not provide sufficient protection against crafted inputs. An authenticated and authorized user can bypass connection URL validation using custom input formatting. The resolution enhances connection URL validation and introduces validation for additional related properties. Upgrading to Apache NiFi 1.23.1 is the recommended mitigation.

CNA Affected

[
  {
    "defaultStatus": "unaffected",
    "product": "Apache NiFi",
    "vendor": "Apache Software Foundation",
    "versions": [
      {
        "lessThanOrEqual": "1.23.0",
        "status": "affected",
        "version": "1.21.0",
        "versionType": "semver"
      }
    ]
  }
]

AI Score

6.6

Confidence

High

EPSS

0.001

Percentile

42.8%

Related for CVELIST:CVE-2023-40037