Lucene search

K
cvelistHackeroneCVELIST:CVE-2021-22898
HistoryJun 11, 2021 - 3:49 p.m.

CVE-2021-22898

2021-06-1115:49:37
CWE-200
hackerone
www.cve.org
4

AI Score

5.5

Confidence

High

EPSS

0.002

Percentile

58.3%

curl 7.7 through 7.76.1 suffers from an information disclosure when the -t command line option, known as CURLOPT_TELNETOPTIONS in libcurl, is used to send variable=content pairs to TELNET servers. Due to a flaw in the option parser for sending NEW_ENV variables, libcurl could be made to pass on uninitialized data from a stack based buffer to the server, resulting in potentially revealing sensitive internal information to the server using a clear-text network protocol.

CNA Affected

[
  {
    "product": "https://github.com/curl/curl",
    "vendor": "n/a",
    "versions": [
      {
        "status": "affected",
        "version": "7.7 through 7.76.1"
      }
    ]
  }
]

References