Lucene search

K
cvelistGoogleCVELIST:CVE-2021-22543
HistoryMay 18, 2021 - 12:00 a.m.

CVE-2021-22543 Improper memory handling in Linux KVM

2021-05-1800:00:00
CWE-119
Google
www.cve.org
3

8.7 High

CVSS4

Attack Vector

LOCAL

Attack Complexity

HIGH

Privileges Required

LOW

User Interaction

NONE

CVSS:4.0/AV:L/AC:H/AT:N/PR:L/UI:N/VC:H/SC:H/VI:H/SI:H/VA:L/SA:L

8 High

AI Score

Confidence

High

0.0004 Low

EPSS

Percentile

5.1%

An issue was discovered in Linux: KVM through Improper handling of VM_IO|VM_PFNMAP vmas in KVM can bypass RO checks and can lead to pages being freed while still accessible by the VMM and guest. This allows users with the ability to start and control a VM to read/write random pages of memory and can result in local privilege escalation.

CNA Affected

[
  {
    "defaultStatus": "unaffected",
    "product": "Linux Kernel",
    "repo": "https://github.com/torvalds/linux",
    "vendor": "Linux Kernel",
    "versions": [
      {
        "lessThan": "f8be156be163a052a067306417cd0ff679068c97",
        "status": "affected",
        "version": "add6a0cd1c5ba51b201e1361b05a5df817083618",
        "versionType": "git"
      }
    ]
  }
]

8.7 High

CVSS4

Attack Vector

LOCAL

Attack Complexity

HIGH

Privileges Required

LOW

User Interaction

NONE

CVSS:4.0/AV:L/AC:H/AT:N/PR:L/UI:N/VC:H/SC:H/VI:H/SI:H/VA:L/SA:L

8 High

AI Score

Confidence

High

0.0004 Low

EPSS

Percentile

5.1%