Lucene search

K
cve[email protected]CVE-2024-3494
HistoryMay 08, 2024 - 6:15 a.m.

CVE-2024-3494

2024-05-0806:15:07
web.nvd.nist.gov
31
wordpress
mesmerize
plugin
xss
vulnerability
input sanitization
output escaping
user attributes
authenticated attackers
contributor-level access

6.4 Medium

CVSS3

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

LOW

User Interaction

NONE

Scope

CHANGED

Confidentiality Impact

LOW

Integrity Impact

LOW

Availability Impact

NONE

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N

5.7 Medium

AI Score

Confidence

High

0.0004 Low

EPSS

Percentile

14.1%

The Mesmerize Companion plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin’s β€˜mesmerize_contact_form’ shortcode in all versions up to, and including, 1.6.148 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

Affected configurations

Vulners
Node
horearadumesmerize_companionRange≀1.6.148

CNA Affected

[
  {
    "vendor": "horearadu",
    "product": "Mesmerize Companion",
    "versions": [
      {
        "version": "*",
        "status": "affected",
        "lessThanOrEqual": "1.6.148",
        "versionType": "semver"
      }
    ],
    "defaultStatus": "unaffected"
  }
]

6.4 Medium

CVSS3

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

LOW

User Interaction

NONE

Scope

CHANGED

Confidentiality Impact

LOW

Integrity Impact

LOW

Availability Impact

NONE

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N

5.7 Medium

AI Score

Confidence

High

0.0004 Low

EPSS

Percentile

14.1%

Related for CVE-2024-3494