Lucene search

K
cve[email protected]CVE-2024-34068
HistoryMay 03, 2024 - 6:15 p.m.

CVE-2024-34068

2024-05-0318:15:09
CWE-441
CWE-284
web.nvd.nist.gov
28
pterodactyl panel
access control
bypass
vulnerability
version 1.11.2
remote download

CVSS3

6.4

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

LOW

User Interaction

NONE

Scope

CHANGED

Confidentiality Impact

LOW

Integrity Impact

LOW

Availability Impact

NONE

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N

AI Score

6.3

Confidence

Low

EPSS

0

Percentile

15.5%

Pterodactyl wings is the server control plane for Pterodactyl Panel. An authenticated user who has access to a game server is able to bypass the previously implemented access control (GHSA-6rg3-8h8x-5xfv) that prevents accessing internal endpoints of the node hosting Wings in the pull endpoint. This would allow malicious users to potentially access resources on local networks that would otherwise be inaccessible. This issue has been addressed in version 1.11.2 and users are advised to upgrade. Users unable to upgrade may enable the api.disable_remote_download option as a workaround.

Affected configurations

Vulners
Node
pterodactylwingsRange<1.11.12
VendorProductVersionCPE
pterodactylwings*cpe:2.3:a:pterodactyl:wings:*:*:*:*:*:*:*:*

CNA Affected

[
  {
    "vendor": "pterodactyl",
    "product": "wings",
    "versions": [
      {
        "version": "< 1.11.12",
        "status": "affected"
      }
    ]
  }
]

CVSS3

6.4

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

LOW

User Interaction

NONE

Scope

CHANGED

Confidentiality Impact

LOW

Integrity Impact

LOW

Availability Impact

NONE

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N

AI Score

6.3

Confidence

Low

EPSS

0

Percentile

15.5%

Related for CVE-2024-34068