Lucene search

K
cve[email protected]CVE-2024-24771
HistoryFeb 07, 2024 - 3:15 p.m.

CVE-2024-24771

2024-02-0715:15:08
CWE-654
CWE-284
CWE-287
web.nvd.nist.gov
19
open forms
cve-2024-24771
security weakness
multi-factor authentication
user hijacking
data abuse
smart forms

7.7 High

CVSS3

Attack Vector

NETWORK

Attack Complexity

HIGH

Privileges Required

HIGH

User Interaction

NONE

Scope

CHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

NONE

CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:N

5.8 Medium

AI Score

Confidence

High

0.001 Low

EPSS

Percentile

32.5%

Open Forms allows users create and publish smart forms. Versions prior to 2.2.9, 2.3.7, 2.4.5, and 2.5.2 contain a non-exploitable multi-factor authentication weakness. Superusers who have their credentials (username + password) compromised could potentially have the second-factor authentication bypassed if an attacker somehow managed to authenticate to Open Forms. The maintainers of Open Forms do not believe it is or has been possible to perform this login. However, if this were possible, the victim’s account may be abused to view (potentially sensitive) submission data or have been used to impersonate other staff accounts to view and/or modify data. Three mitigating factors to help prevent exploitation include: the usual login page (at /admin/login/) does not fully log in the user until the second factor was succesfully provided; the additional non-MFA protected login page at /api/v2/api-authlogin/ was misconfigured and could not be used to log in; and there are no additional ways to log in. This also requires credentials of a superuser to be compromised to be exploitable. Versions 2.2.9, 2.3.7, 2.4.5, and 2.5.2 contain the following patches to address these weaknesses: Move and only enable the API auth endpoints (/api/v2/api-auth/login/) with settings.DEBUG = True. settings.DEBUG = True is insecure and should never be applied in production settings. Additionally, apply a custom permission check to the hijack flow to only allow second-factor-verified superusers to perform user hijacking.

Affected configurations

Vulners
NVD
Node
open-formulierenopen_formsRange<2.2.9
OR
open-formulierenopen_formsRange2.3.0–2.3.7
OR
open-formulierenopen_formsRange2.4.0–2.4.4
OR
open-formulierenopen_formsRange2.5.0–2.5.0

CNA Affected

[
  {
    "vendor": "open-formulieren",
    "product": "open-forms",
    "versions": [
      {
        "version": "< 2.2.9",
        "status": "affected"
      },
      {
        "version": ">= 2.3.0, < 2.3.7",
        "status": "affected"
      },
      {
        "version": ">= 2.4.0, < 2.4.4",
        "status": "affected"
      },
      {
        "version": ">= 2.5.0, < 2.5.0",
        "status": "affected"
      }
    ]
  }
]

7.7 High

CVSS3

Attack Vector

NETWORK

Attack Complexity

HIGH

Privileges Required

HIGH

User Interaction

NONE

Scope

CHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

NONE

CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:N

5.8 Medium

AI Score

Confidence

High

0.001 Low

EPSS

Percentile

32.5%

Related for CVE-2024-24771