Lucene search

K
cve[email protected]CVE-2024-0203
HistoryMar 07, 2024 - 8:15 p.m.

CVE-2024-0203

2024-03-0720:15:50
web.nvd.nist.gov
81
wordpress
digits plugin
cve-2024-0203
csrf
cross-site request forgery
user privileges

8.8 High

CVSS3

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

REQUIRED

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

8.3 High

AI Score

Confidence

High

0.0004 Low

EPSS

Percentile

9.0%

The Digits plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 8.4.1. This is due to missing nonce validation in the β€˜digits_save_settings’ function. This makes it possible for unauthenticated attackers to modify the default role of registered users to elevate user privileges via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

Affected configurations

Vulners
Node
unitedoverdigits\Match_wordpress_mobile_number_signup_and_login8.4.1

CNA Affected

[
  {
    "vendor": "UnitedOver",
    "product": "Digits: WordPress Mobile Number Signup and Login",
    "versions": [
      {
        "version": "8.4.1",
        "status": "affected"
      }
    ],
    "defaultStatus": "unaffected"
  }
]

8.8 High

CVSS3

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

REQUIRED

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

8.3 High

AI Score

Confidence

High

0.0004 Low

EPSS

Percentile

9.0%

Related for CVE-2024-0203