Lucene search
+L

CVE-2023-50709

🗓️ 13 Dec 2023 22:00:04Reported by GitHub_MType 
cve
 cve
🔗 web.nvd.nist.gov👁 68 Views

Cube API in versions prior to 0.34.34 allows denial of service via specially crafted requests. Upgrade to v0.34.34 to prevent disruption

Related
Detection
Affected
Refs
ReporterTitlePublishedViews
Family
circl
Circl
CVE-2023-50709
10 Jan 202415:11
–circl
cnnvd
CNNVD
Cube.js Input Validation Error Vulnerability
13 Dec 202300:00
–cnnvd
cvelist
Cvelist
CVE-2023-50709 Denial of service attack on the cube-api endpoint
13 Dec 202322:00
–cvelist
euvd
EUVD
EUVD-2023-3170
3 Oct 202520:07
–euvd
github
Github Security Blog
Cube API denial of service attack
13 Dec 202323:15
–github
mend
Mend
CVE-2023-50709
13 Dec 202322:00
–mend
nvd
NVD
CVE-2023-50709
13 Dec 202322:15
–nvd
osv_cve
osv_cve
CVE-2023-50709 Denial of service attack on the cube-api endpoint
13 Dec 202322:00
–osv_cve
osv_ghsa
osv_ghsa
GHSA-9759-3276-G2PM Cube API denial of service attack
13 Dec 202323:15
–osv_ghsa
prion
Prion
Design/Logic Flaw
13 Dec 202322:15
–prion
Rows per page
NVD
Node
cubecube.jsRange<0.34.34node.js
[
  {
    "vendor": "cube-js",
    "product": "cube",
    "versions": [
      {
        "version": "< 0.34.34",
        "status": "affected"
      }
    ]
  }
]

Data

Build on a solid foundation with Vulners data

We provide the essential building blocks for cybersecurity solutions with comprehensive, structured, and constantly updated vulnerability and exploits data

Api

Power your application with Vulners API

The Vulners REST API offers reliable, high-performance access to vulnerability intelligence, with 99.9% SLA uptime and CDN-backed data delivery for seamless global access

App

Assess and manage vulnerabilities with Vulners tools

Built on top of Vulners' database and SDK, end-user solutions give security professionals and developers lightweight and powerful tools for vulnerability remediation

17 Jun 2026 06:39Current
7High risk
Vulners AI Score7
CVSS 3.16.5 - 7.5
EPSS0.00722
SSVC
68