Lucene search

K
cve[email protected]CVE-2023-46725
HistoryNov 02, 2023 - 3:15 p.m.

CVE-2023-46725

2023-11-0215:15:08
CWE-367
CWE-918
web.nvd.nist.gov
22
foodcoopshop
open source software
vulnerability
server-side request forgery
ssrf
network security
cybersecurity
nvd
cve-2023-46725

8.1 High

CVSS3

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

LOW

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

NONE

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

0.001 Low

EPSS

Percentile

29.5%

FoodCoopShop is open source software for food coops and local shops. Versions starting with 3.2.0 prior to 3.6.1 are vulnerable to server-side request forgery. In the Network module, a manufacturer account can use the /api/updateProducts.json endpoint to make the server send a request to an arbitrary host. This means that the server can be used as a proxy into the internal network where the server is. Furthermore, the checks on a valid image are not adequate, leading to a time of check time of use issue. For example, by using a custom server that returns 200 on HEAD requests, then return a valid image on first GET request and then a 302 redirect to final target on second GET request, the server will copy whatever file is at the redirect destination, making this a full SSRF. Version 3.6.1 fixes this vulnerability.

Affected configurations

Vulners
NVD
Node
foodcoopshopfoodcoopshopRange3.2.03.6.1
VendorProductVersionCPE
foodcoopshopfoodcoopshop*cpe:2.3:a:foodcoopshop:foodcoopshop:*:*:*:*:*:*:*:*

CNA Affected

[
  {
    "vendor": "foodcoopshop",
    "product": "foodcoopshop",
    "versions": [
      {
        "version": ">= 3.2.0, < 3.6.1",
        "status": "affected"
      }
    ]
  }
]

8.1 High

CVSS3

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

LOW

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

NONE

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

0.001 Low

EPSS

Percentile

29.5%

Related for CVE-2023-46725