Lucene search

K
cve[email protected]CVE-2023-38573
HistoryNov 27, 2023 - 4:15 p.m.

CVE-2023-38573

2023-11-2716:15:10
CWE-416
web.nvd.nist.gov
12
cve-2023-38573
use-after-free vulnerability
foxit reader
arbitrary code execution
pdf
memory corruption
javascript
browser plugin
nvd

8.8 High

CVSS3

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

REQUIRED

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

8.8 High

AI Score

Confidence

High

0.001 Low

EPSS

Percentile

50.5%

A use-after-free vulnerability exists in the way Foxit Reader 12.1.2.15356 handles a signature field. A specially crafted Javascript code inside a malicious PDF document can trigger reuse of a previously freed object, which can lead to memory corruption and result in arbitrary code execution. An attacker needs to trick the user into opening the malicious file to trigger this vulnerability. Exploitation is also possible if a user visits a specially crafted, malicious site if the browser plugin extension is enabled.

Affected configurations

Vulners
NVD
Node
foxitreaderRange12.1.3.15356
VendorProductVersionCPE
foxitreader*cpe:2.3:a:foxit:reader:*:*:*:*:*:*:*:*

CNA Affected

[
  {
    "vendor": "Foxit",
    "product": "Foxit Reader",
    "versions": [
      {
        "version": "12.1.3.15356",
        "status": "affected"
      }
    ]
  }
]

8.8 High

CVSS3

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

REQUIRED

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

8.8 High

AI Score

Confidence

High

0.001 Low

EPSS

Percentile

50.5%