Lucene search

K
cve[email protected]CVE-2023-32315
HistoryMay 26, 2023 - 11:15 p.m.

CVE-2023-32315

2023-05-2623:15:16
CWE-22
web.nvd.nist.gov
396
In Wild
openfire
xmpp
server
admin console
path traversal
vulnerability
cve-2023-32315
nvd
apache license

8.6 High

CVSS3

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

LOW

Availability Impact

LOW

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L

7.7 High

AI Score

Confidence

High

0.973 High

EPSS

Percentile

99.9%

Openfire is an XMPP server licensed under the Open Source Apache License. Openfire’s administrative console, a web-based application, was found to be vulnerable to a path traversal attack via the setup environment. This permitted an unauthenticated user to use the unauthenticated Openfire Setup Environment in an already configured Openfire environment to access restricted pages in the Openfire Admin Console reserved for administrative users. This vulnerability affects all versions of Openfire that have been released since April 2015, starting with version 3.10.0. The problem has been patched in Openfire release 4.7.5 and 4.6.8, and further improvements will be included in the yet-to-be released first version on the 4.8 branch (which is expected to be version 4.8.0). Users are advised to upgrade. If an Openfire upgrade isn’t available for a specific release, or isn’t quickly actionable, users may see the linked github advisory (GHSA-gw42-f939-fhvm) for mitigation advice.

Affected configurations

Vulners
NVD
Node
igniterealtimeopenfireRange3.10.04.6.8
OR
igniterealtimeopenfireRange4.7.04.7.5
VendorProductVersionCPE
igniterealtimeopenfire*cpe:2.3:a:igniterealtime:openfire:*:*:*:*:*:*:*:*
igniterealtimeopenfire*cpe:2.3:a:igniterealtime:openfire:*:*:*:*:*:*:*:*

CNA Affected

[
  {
    "vendor": "igniterealtime",
    "product": "Openfire",
    "versions": [
      {
        "version": ">= 3.10.0, < 4.6.8",
        "status": "affected"
      },
      {
        "version": ">= 4.7.0, < 4.7.5",
        "status": "affected"
      }
    ]
  }
]

8.6 High

CVSS3

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

LOW

Availability Impact

LOW

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L

7.7 High

AI Score

Confidence

High

0.973 High

EPSS

Percentile

99.9%