Lucene search

K
cve[email protected]CVE-2022-43667
HistoryDec 07, 2022 - 4:15 a.m.

CVE-2022-43667

2022-12-0704:15:10
CWE-787
web.nvd.nist.gov
27
cve-2022-43667
stack-based buffer overflow
cx-programmer
information disclosure
arbitrary code execution
nvd

7.8 High

CVSS3

Attack Vector

LOCAL

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

REQUIRED

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

7.7 High

AI Score

Confidence

High

0.002 Low

EPSS

Percentile

52.6%

Stack-based buffer overflow vulnerability exists in CX-Programmer v.9.77 and earlier, which may lead to information disclosure and/or arbitrary code execution by having a user to open a specially crafted CXP file.

Affected configurations

Vulners
NVD
Node
omroncx-programmerMatch9.77
VendorProductVersionCPE
omroncx\-programmer9.77cpe:2.3:a:omron:cx\-programmer:9.77:*:*:*:*:*:*:*

CNA Affected

[
  {
    "vendor": "OMRON Corporation",
    "product": "CX-Programmer",
    "versions": [
      {
        "version": "v.9.77 and earlier",
        "status": "affected"
      }
    ]
  }
]

7.8 High

CVSS3

Attack Vector

LOCAL

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

REQUIRED

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

7.7 High

AI Score

Confidence

High

0.002 Low

EPSS

Percentile

52.6%

Related for CVE-2022-43667