Lucene search

K
cve[email protected]CVE-2022-39232
HistorySep 29, 2022 - 9:15 p.m.

CVE-2022-39232

2022-09-2921:15:11
CWE-20
web.nvd.nist.gov
20
6
cve-2022-39232
discourse
open source
discussion platform
incomplete quote
javascript error
fix
version 2.9.0.beta10
nvd

6.5 Medium

CVSS3

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

LOW

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

NONE

Integrity Impact

NONE

Availability Impact

HIGH

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

4.6 Medium

AI Score

Confidence

High

0.001 Low

EPSS

Percentile

36.3%

Discourse is an open source discussion platform. Starting with version 2.9.0.beta5 and prior to version 2.9.0.beta10, an incomplete quote can generate a JavaScript error which will crash the current page in the browser in some cases. Version 2.9.0.beta10 added a fix and tests to ensure incomplete quotes won’t break the app. As a workaround, the quote can be fixed via the rails console.

Affected configurations

Vulners
NVD
Node
discoursediscourseRange2.9.0.beta5–2.9.0.beta10
VendorProductVersionCPE
discoursediscourse*cpe:2.3:a:discourse:discourse:*:*:*:*:*:*:*:*

CNA Affected

[
  {
    "product": "discourse",
    "vendor": "discourse",
    "versions": [
      {
        "status": "affected",
        "version": ">= 2.9.0.beta5, < 2.9.0.beta10"
      }
    ]
  }
]

Social References

More

6.5 Medium

CVSS3

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

LOW

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

NONE

Integrity Impact

NONE

Availability Impact

HIGH

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

4.6 Medium

AI Score

Confidence

High

0.001 Low

EPSS

Percentile

36.3%

Related for CVE-2022-39232