Lucene search

K
cve[email protected]CVE-2022-29886
HistoryAug 05, 2022 - 10:15 p.m.

CVE-2022-29886

2022-08-0522:15:11
CWE-190
CWE-680
web.nvd.nist.gov
89
5
cve-2022-29886
integer overflow
vulnerability
estsoft alyac
ole files
heap buffer overflow
arbitrary code execution
nvd

7.8 High

CVSS3

Attack Vector

LOCAL

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

REQUIRED

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

6.9 Medium

AI Score

Confidence

High

0.001 Low

EPSS

Percentile

43.9%

An integer overflow vulnerability exists in the way ESTsoft Alyac 2.5.8.544 parses OLE files. A specially-crafted OLE file can lead to a heap buffer overflow, which can result in arbitrary code execution. An attacker can provide a malicious file to trigger this vulnerability.

Affected configurations

Vulners
NVD
Node
estsoftalyacRange2.5.8.544
VendorProductVersionCPE
estsoftalyac*cpe:2.3:a:estsoft:alyac:*:*:*:*:*:*:*:*

CNA Affected

[
  {
    "product": "Alyac",
    "vendor": "ESTsoft",
    "versions": [
      {
        "status": "affected",
        "version": "2.5.8.544"
      }
    ]
  }
]

Social References

More

7.8 High

CVSS3

Attack Vector

LOCAL

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

REQUIRED

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

6.9 Medium

AI Score

Confidence

High

0.001 Low

EPSS

Percentile

43.9%

Related for CVE-2022-29886