Lucene search

K
cve[email protected]CVE-2022-21208
HistoryAug 23, 2022 - 5:15 a.m.

CVE-2022-21208

2022-08-2305:15:07
CWE-1284
web.nvd.nist.gov
35
2
cve-2022-21208
node-opcua
denial of service
vulnerability
nvd
security

7.5 High

CVSS3

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

NONE

Integrity Impact

NONE

Availability Impact

HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

0.001 Low

EPSS

Percentile

51.1%

The package node-opcua before 2.74.0 are vulnerable to Denial of Service (DoS) due to a missing limitation on the number of received chunks - per single session or in total for all concurrent sessions. An attacker can exploit this vulnerability by sending an unlimited number of huge chunks (e.g. 2GB each) without sending the Final closing chunk.

Affected configurations

NVD
Node
node-opcua_projectnode-opcuaRange<2.74.0node.js

CNA Affected

[
  {
    "product": "node-opcua",
    "vendor": "n/a",
    "versions": [
      {
        "lessThan": "2.74.0",
        "status": "affected",
        "version": "unspecified",
        "versionType": "custom"
      }
    ]
  }
]

Social References

More

7.5 High

CVSS3

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

NONE

Integrity Impact

NONE

Availability Impact

HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

0.001 Low

EPSS

Percentile

51.1%

Related for CVE-2022-21208