logo
DATABASE RESOURCES PRICING ABOUT US

CVE-2021-45463

Description

load_cache in GEGL before 0.4.34 allows shell expansion when a pathname in a constructed command line is not escaped or filtered. This is caused by use of the system library function for execution of the ImageMagick convert fallback in magick-load. NOTE: GEGL releases before 0.4.34 are used in GIMP releases before 2.10.30; however, this does not imply that GIMP builds enable the vulnerable feature.


Affected Software


CPE Name Name Version
gegl:gegl gegl 0.4.34
gimp:gimp gimp 2.10.30
redhat:enterprise_linux redhat enterprise linux 7.0
redhat:enterprise_linux redhat enterprise linux 8.0
fedoraproject:fedora fedoraproject fedora 34
fedoraproject:fedora fedoraproject fedora 35

Related