logo
DATABASE RESOURCES PRICING ABOUT US

CVE-2021-34630

Description

In the Pro and Enterprise versions of GTranslate < 2.8.65, the gtranslate_request_uri_var function runs at the top of all pages and echoes out the contents of $_SERVER['REQUEST_URI']. Although this uses addslashes, and most modern browsers automatically URLencode requests, this plugin is still vulnerable to Reflected XSS in older browsers such as Internet Explorer 9 or below, or in cases where an attacker is able to modify the request en route between the client and the server, or in cases where the user is using an atypical browsing solution.


Affected Software


CPE Name Name Version
gtranslate:gtranslate gtranslate 2.8.65
gtranslate:gtranslate gtranslate 2.8.65

Related