logo
DATABASE RESOURCES PRICING ABOUT US

CVE-2021-34371

Description

Neo4j through 3.4.18 (with the shell server enabled) exposes an RMI service that arbitrarily deserializes Java objects, e.g., through setSessionVariable. An attacker can abuse this for remote code execution because there are dependencies with exploitable gadget chains.


Affected Software


CPE Name Name Version
neo4j:neo4j neo4j 3.4.18

Related