logo
DATABASE RESOURCES PRICING ABOUT US

CVE-2020-25757

Description

A lack of input validation and access controls in Lua CGIs on D-Link DSR VPN routers may result in arbitrary input being passed to system command APIs, resulting in arbitrary command execution with root privileges. This affects DSR-150, DSR-250, DSR-500, and DSR-1000AC with firmware 3.14 and 3.17.


Affected Software


CPE Name Name Version
dlink:dsr-150_firmware dlink dsr-150 firmware 3.17
dlink:dsr-150n_firmware dlink dsr-150n firmware 3.17
dlink:dsr-250_firmware dlink dsr-250 firmware 3.17
dlink:dsr-250n_firmware dlink dsr-250n firmware 3.17
dlink:dsr-500_firmware dlink dsr-500 firmware 3.17
dlink:dsr-500n_firmware dlink dsr-500n firmware *
dlink:dsr-500ac_firmware dlink dsr-500ac firmware 3.17
dlink:dsr-1000_firmware dlink dsr-1000 firmware 3.17
dlink:dsr-1000n_firmware dlink dsr-1000n firmware 3.17
dlink:dsr-1000ac_firmware dlink dsr-1000ac firmware 3.17

Related