CVE-2020-12403

2021-05-27T19:15:00
ID CVE-2020-12403
Type cve
Reporter security@mozilla.org
Modified 2021-06-09T14:42:00

Description

A flaw was found in the way CHACHA20-POLY1305 was implemented in NSS in versions before 3.55. When using multi-part Chacha20, it could cause out-of-bounds reads. This issue was fixed by explicitly disabling multi-part ChaCha20 (which was not functioning correctly) and strictly enforcing tag length. The highest threat from this vulnerability is to confidentiality and system availability.