logo
DATABASE RESOURCES PRICING ABOUT US

CVE-2020-10018

Description

WebKitGTK through 2.26.4 and WPE WebKit through 2.26.4 (which are the versions right before 2.28.0) contains a memory corruption issue (use-after-free) that may lead to arbitrary code execution. This issue has been fixed in 2.28.0 with improved memory handling.


Affected Software


CPE Name Name Version
webkitgtk:webkitgtk webkitgtk 2.28.0
wpewebkit:wpe_webkit wpewebkit wpe webkit 2.28.0
fedoraproject:fedora fedoraproject fedora 30
fedoraproject:fedora fedoraproject fedora 31
debian:debian_linux debian debian linux 10.0
canonical:ubuntu_linux canonical ubuntu linux 18.04
canonical:ubuntu_linux canonical ubuntu linux 19.10
opensuse:leap opensuse leap 15.1

Related