CVE-2018-3893

2018-08-27T15:29:00
ID CVE-2018-3893
Type cve
Reporter cve@mitre.org
Modified 2018-11-09T19:05:00

Description

An exploitable buffer overflow vulnerability exists in the /cameras/XXXX/clips handler of video-core's HTTP server of Samsung SmartThings Hub STH-ETH-250 - Firmware version 0.20.17. The video-core process incorrectly extracts fields from a user-controlled JSON payload, leading to a buffer overflow on the stack. An attacker can send an HTTP request to trigger this vulnerability.