CVE-2018-1000814

2018-12-20T15:29:00
ID CVE-2018-1000814
Type cve
Reporter cve@mitre.org
Modified 2019-09-19T17:40:00

Description

aio-libs aiohttp-session version 2.6.0 and earlier contains a Other/Unknown vulnerability in EncryptedCookieStorage and NaClCookieStorage that can result in Non-expiring sessions / Infinite lifespan. This attack appear to be exploitable via Recreation of a cookie post-expiry with the same value.