logo
DATABASE RESOURCES PRICING ABOUT US

CVE-2017-9798

Description

Apache httpd allows remote attackers to read secret data from process memory if the Limit directive can be set in a user's .htaccess file, or if httpd.conf has certain misconfigurations, aka Optionsbleed. This affects the Apache HTTP Server through 2.2.34 and 2.4.x through 2.4.27. The attacker sends an unauthenticated OPTIONS HTTP request when attempting to read secret data. This is a use-after-free issue and thus secret data is not always sent, and the specific data depends on many factors including configuration. Exploitation with .htaccess can be blocked with a patch to the ap_limit_section function in server/core.c.


Affected Software


CPE Name Name Version
apache:http_server apache http server 2.4.0
apache:http_server apache http server 2.4.9
apache:http_server apache http server 2.4.10
apache:http_server apache http server 2.4.26
apache:http_server apache http server 2.4.27
apache:http_server apache http server 2.4.6
apache:http_server apache http server 2.4.7
apache:http_server apache http server 2.4.23
apache:http_server apache http server 2.4.25
apache:http_server apache http server 2.4.3
apache:http_server apache http server 2.4.4
apache:http_server apache http server 2.4.17
apache:http_server apache http server 2.4.18
apache:http_server apache http server 2.4.20
apache:http_server apache http server 2.4.1
apache:http_server apache http server 2.4.2
apache:http_server apache http server 2.4.12
apache:http_server apache http server 2.4.16
apache:http_server apache http server 2.2.34
debian:debian_linux debian debian linux 7.0
debian:debian_linux debian debian linux 9.0
debian:debian_linux debian debian linux 8.0

Related