CVE-2017-5577

2017-02-06T06:59:00
ID CVE-2017-5577
Type cve
Reporter cve@mitre.org
Modified 2017-02-08T18:32:00

Description

The vc4_get_bcl function in drivers/gpu/drm/vc4/vc4_gem.c in the VideoCore DRM driver in the Linux kernel before 4.9.7 does not set an errno value upon certain overflow detections, which allows local users to cause a denial of service (incorrect pointer dereference and OOPS) via inconsistent size values in a VC4_SUBMIT_CL ioctl call.