Lucene search

K
cve[email protected]CVE-2017-5176
HistoryMay 19, 2017 - 3:29 a.m.

CVE-2017-5176

2017-05-1903:29:00
CWE-427
web.nvd.nist.gov
27
cve-2017-5176
dll hijack
rockwell automation
connected components workbench
ccw
security vulnerability
nvd

7 High

CVSS3

Attack Vector

LOCAL

Attack Complexity

HIGH

Privileges Required

NONE

User Interaction

REQUIRED

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.0/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

7 High

AI Score

Confidence

High

6.2 Medium

CVSS2

Access Vector

Access Complexity

Authentication

NONE

Confidentiality Impact

COMPLETE

Integrity Impact

COMPLETE

Availability Impact

COMPLETE

AV:L/AC:H/Au:N/C:C/I:C/A:C

0.001 Low

EPSS

Percentile

20.2%

A DLL Hijack issue was discovered in Rockwell Automation Connected Components Workbench (CCW). The following versions are affected: Connected Components Workbench - Developer Edition, v9.01.00 and earlier: 9328-CCWDEVENE, 9328-CCWDEVZHE, 9328-CCWDEVFRE, 9328-CCWDEVITE, 9328-CCWDEVDEE, 9328-CCWDEVESE, and 9328-CCWDEVPTE; and Connected Components Workbench - Free Standard Edition (All Supported Languages), v9.01.00 and earlier. Certain DLLs included with versions of CCW software can be potentially hijacked to allow an attacker to gain rights to a victim’s affected personal computer. Such access rights can be at the same or potentially higher level of privileges as the compromised user account, including and up to computer administrator privileges.

Affected configurations

NVD
Node
rockwellautomationconnected_components_workbenchRange≀9.01.00developer
AND
rockwellautomation9328-ccwdevdeeMatch-
OR
rockwellautomation9328-ccwdeveneMatch-
OR
rockwellautomation9328-ccwdeveseMatch-
OR
rockwellautomation9328-ccwdevfreMatch-
OR
rockwellautomation9328-ccwdeviteMatch-
OR
rockwellautomation9328-ccwdevpteMatch-
OR
rockwellautomation9328-ccwdevzheMatch-
Node
rockwellautomationconnected_components_workbenchRange≀9.01.00free_standard

CNA Affected

[
  {
    "product": "Rockwell Automation Connected Components Workbench",
    "vendor": "n/a",
    "versions": [
      {
        "status": "affected",
        "version": "Rockwell Automation Connected Components Workbench"
      }
    ]
  }
]

7 High

CVSS3

Attack Vector

LOCAL

Attack Complexity

HIGH

Privileges Required

NONE

User Interaction

REQUIRED

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.0/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

7 High

AI Score

Confidence

High

6.2 Medium

CVSS2

Access Vector

Access Complexity

Authentication

NONE

Confidentiality Impact

COMPLETE

Integrity Impact

COMPLETE

Availability Impact

COMPLETE

AV:L/AC:H/Au:N/C:C/I:C/A:C

0.001 Low

EPSS

Percentile

20.2%

Related for CVE-2017-5176