CVE-2017-2607

2018-05-21T23:29:00
ID CVE-2017-2607
Type cve
Reporter cve@mitre.org
Modified 2018-06-26T17:28:00

Description

jenkins before versions 2.44, 2.32.2 is vulnerable to a persisted cross-site scripting vulnerability in console notes (SECURITY-382). Jenkins allows plugins to annotate build logs, adding new content or changing the presentation of existing content while the build is running. Malicious Jenkins users, or users with SCM access, could configure jobs or modify build scripts such that they print serialized console notes that perform cross-site scripting attacks on Jenkins users viewing the build logs.