logo
DATABASE RESOURCES PRICING ABOUT US

CVE-2017-1000111

Description

Linux kernel: heap out-of-bounds in AF_PACKET sockets. This new issue is analogous to previously disclosed CVE-2016-8655. In both cases, a socket option that changes socket state may race with safety checks in packet_set_ring. Previously with PACKET_VERSION. This time with PACKET_RESERVE. The solution is similar: lock the socket for the update. This issue may be exploitable, we did not investigate further. As this issue affects PF_PACKET sockets, it requires CAP_NET_RAW in the process namespace. But note that with user namespaces enabled, any process can create a namespace in which it has CAP_NET_RAW.


Affected Software


CPE Name Name Version
linux:linux_kernel linux linux kernel 4.12.3
redhat:enterprise_linux redhat enterprise linux 6.0
redhat:enterprise_linux redhat enterprise linux 5.0
redhat:enterprise_linux redhat enterprise linux 7.0
redhat:enterprise_linux_desktop redhat enterprise linux desktop 6.0
redhat:enterprise_linux_server_tus redhat enterprise linux server tus 7.6
redhat:enterprise_linux_desktop redhat enterprise linux desktop 7.0
redhat:enterprise_linux_workstation redhat enterprise linux workstation 6.0
redhat:enterprise_linux_server redhat enterprise linux server 7.0
redhat:enterprise_linux_server_aus redhat enterprise linux server aus 7.4
redhat:enterprise_linux_server_eus redhat enterprise linux server eus 7.5
redhat:enterprise_linux_server_eus redhat enterprise linux server eus 7.4
redhat:enterprise_linux_server_eus redhat enterprise linux server eus 7.6
redhat:enterprise_linux_server redhat enterprise linux server 6.0
redhat:enterprise_linux_server_tus redhat enterprise linux server tus 7.4
redhat:enterprise_linux_server_aus redhat enterprise linux server aus 7.6
redhat:enterprise_linux_workstation redhat enterprise linux workstation 7.0
debian:debian_linux debian debian linux 9.0
debian:debian_linux debian debian linux 8.0

Related