logo
DATABASE RESOURCES PRICING ABOUT US

CVE-2016-9592

Description

openshift before versions 3.3.1.11, 3.2.1.23, 3.4 is vulnerable to a flaw when a volume fails to detach, which causes the delete operation to fail with 'VolumeInUse' error. Since the delete operation is retried every 30 seconds for each volume, this could lead to a denial of service attack as the number of API requests being sent to the cloud-provider exceeds the API's rate-limit.


Affected Software


CPE Name Name Version
redhat:openshift redhat openshift 3.3.1.11
redhat:openshift redhat openshift 3.2.1.23
redhat:openshift redhat openshift 3.4

Related