CVE-2016-3959

2016-05-23T19:59:00
ID CVE-2016-3959
Type cve
Reporter cve@mitre.org
Modified 2018-10-30T16:27:00

Description

The Verify function in crypto/dsa/dsa.go in Go before 1.5.4 and 1.6.x before 1.6.1 does not properly check parameters passed to the big integer library, which might allow remote attackers to cause a denial of service (infinite loop) via a crafted public key to a program that uses HTTPS client certificates or SSH server libraries.