CVE-2016-10724

2018-07-05T22:29:00
ID CVE-2016-10724
Type cve
Reporter cve@mitre.org
Modified 2020-03-18T17:07:00

Description

Bitcoin Core before v0.13.0 allows denial of service (memory exhaustion) triggered by the remote network alert system (deprecated since Q1 2016) if an attacker can sign a message with a certain private key that had been known by unintended actors, because of an infinitely sized map. This affects other uses of the codebase, such as Bitcoin Knots before v0.13.0.knots20160814 and many altcoins.