CVE-2016-1000346

2018-06-04T21:29:00
ID CVE-2016-1000346
Type cve
Reporter cve@mitre.org
Modified 2018-11-28T11:29:00

Description

In the Bouncy Castle JCE Provider version 1.55 and earlier the other party DH public key is not fully validated. This can cause issues as invalid keys can be used to reveal details about the other party's private key where static Diffie-Hellman is in use. As of release 1.56 the key parameters are checked on agreement calculation.