CVE-2014-1928

2014-10-25T21:55:00
ID CVE-2014-1928
Type cve
Reporter cve@mitre.org
Modified 2014-10-27T19:24:00

Description

The shell_quote function in python-gnupg 0.3.5 does not properly escape characters, which allows context-dependent attackers to execute arbitrary code via shell metacharacters in unspecified vectors, as demonstrated using "\" (backslash) characters to form multi-command sequences, a different vulnerability than CVE-2014-1927. NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-7323.