CVE-2012-4402

2012-09-19T10:57:00
ID CVE-2012-4402
Type cve
Reporter cve@mitre.org
Modified 2012-10-26T04:00:00

Description

webservice/lib.php in Moodle 2.1.x before 2.1.8, 2.2.x before 2.2.5, and 2.3.x before 2.3.2 does not properly restrict the use of web-service tokens, which allows remote authenticated users to run arbitrary external-service functions via a token intended for only one service.