CVE-2012-3398

2012-07-23T21:55:00
ID CVE-2012-3398
Type cve
Reporter cve@mitre.org
Modified 2017-12-01T02:29:00

Description

Algorithmic complexity vulnerability in Moodle 1.9.x before 1.9.19, 2.0.x before 2.0.10, 2.1.x before 2.1.7, and 2.2.x before 2.2.4 allows remote authenticated users to cause a denial of service (CPU consumption) by using the advanced-search feature on a database activity that has many records. Per: http://cwe.mitre.org/data/definitions/407.html 'CWE-407: Algorithmic Complexity'