logo
DATABASE RESOURCES PRICING ABOUT US

CVE-2011-3871

Description

Puppet 2.7.x before 2.7.5, 2.6.x before 2.6.11, and 0.25.x, when running in --edit mode, uses a predictable file name, which allows local users to run arbitrary Puppet code or trick a user into editing arbitrary files.


Affected Software


CPE Name Name Version
puppet:puppet puppet 2.7.2
puppetlabs:puppet puppetlabs puppet 2.7.1
puppet:puppet puppet 2.6.4
puppet:puppet puppet 2.6.3
puppet:puppet puppet 2.6.10
puppet:puppet puppet 2.6.0
puppet:puppet puppet 2.6.6
puppet:puppet puppet 2.6.5
puppetlabs:puppet puppetlabs puppet 2.7.0
puppet:puppet puppet 2.7.4
puppet:puppet puppet 2.6.2
puppet:puppet puppet 2.6.1
puppet:puppet puppet 2.7.3
puppet:puppet puppet 2.6.9
puppet:puppet puppet 2.6.8
puppet:puppet puppet 2.6.7
puppet:puppet puppet 0.25.4
puppet:puppet puppet 0.25.5
puppet:puppet puppet 0.25.3
puppet:puppet puppet 0.25.2
puppet:puppet puppet 0.25.1
puppet:puppet puppet 0.25.0
puppet:puppet puppet 0.25.6

Related