logo
DATABASE RESOURCES PRICING ABOUT US

CVE-2011-3870

Description

Puppet 2.7.x before 2.7.5, 2.6.x before 2.6.11, and 0.25.x allows local users to modify the permissions of arbitrary files via a symlink attack on the SSH authorized_keys file.


Affected Software


CPE Name Name Version
puppetlabs:puppet puppetlabs puppet 2.7.0
puppet:puppet puppet 2.7.4
puppet:puppet puppet 2.6.2
puppet:puppet puppet 2.6.1
puppet:puppet puppet 2.7.2
puppetlabs:puppet puppetlabs puppet 2.7.1
puppet:puppet puppet 2.6.4
puppet:puppet puppet 2.6.3
puppet:puppet puppet 2.6.10
puppet:puppet puppet 2.6.0
puppet:puppet puppet 2.6.6
puppet:puppet puppet 2.6.5
puppet:puppet puppet 2.7.3
puppet:puppet puppet 2.6.9
puppet:puppet puppet 2.6.8
puppet:puppet puppet 2.6.7
puppet:puppet puppet 0.25.3
puppet:puppet puppet 0.25.2
puppet:puppet puppet 0.25.4
puppet:puppet puppet 0.25.5
puppet:puppet puppet 0.25.1
puppet:puppet puppet 0.25.0
puppet:puppet puppet 0.25.6

Related