CVE-2011-3149

2012-07-22T17:55:00
ID CVE-2011-3149
Type cve
Reporter cve@mitre.org
Modified 2019-01-03T15:01:00

Description

The _expand_arg function in the pam_env module (modules/pam_env/pam_env.c) in Linux-PAM (aka pam) before 1.1.5 does not properly handle when environment variable expansion can overflow, which allows local users to cause a denial of service (CPU consumption).