CVE-2011-2197

2011-06-30T15:55:00
ID CVE-2011-2197
Type cve
Reporter cve@mitre.org
Modified 2012-07-06T04:00:00

Description

The cross-site scripting (XSS) prevention feature in Ruby on Rails 2.x before 2.3.12, 3.0.x before 3.0.8, and 3.1.x before 3.1.0.rc2 does not properly handle mutation of safe buffers, which makes it easier for remote attackers to conduct XSS attacks via crafted strings to an application that uses a problematic string method, as demonstrated by the sub method.