logo
DATABASE RESOURCES PRICING ABOUT US

CVE-2010-2995

Description

The SigComp Universal Decompressor Virtual Machine (UDVM) in Wireshark 0.10.8 through 1.0.14 and 1.2.0 through 1.2.9 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via vectors related to sigcomp-udvm.c and an off-by-one error, which triggers a buffer overflow, different vulnerabilities than CVE-2010-2287.


Affected Software


CPE Name Name Version
wireshark:wireshark wireshark 1.2.9
wireshark:wireshark wireshark 1.2.7
wireshark:wireshark wireshark 1.2.1
wireshark:wireshark wireshark 1.0.5
wireshark:wireshark wireshark 1.0.7
wireshark:wireshark wireshark 1.0.13
wireshark:wireshark wireshark 1.0.14
wireshark:wireshark wireshark 0.10.14
wireshark:wireshark wireshark 1.2.5
wireshark:wireshark wireshark 1.2.8
wireshark:wireshark wireshark 1.0.12
wireshark:wireshark wireshark 1.0.11
wireshark:wireshark wireshark 1.0.10
wireshark:wireshark wireshark 1.0.2
wireshark:wireshark wireshark 0.10.10
wireshark:wireshark wireshark 0.10.11
wireshark:wireshark wireshark 1.2.0
wireshark:wireshark wireshark 1.2.4
wireshark:wireshark wireshark 1.0.1
wireshark:wireshark wireshark 1.0.4
wireshark:wireshark wireshark 1.0.3
wireshark:wireshark wireshark 1.0.0
wireshark:wireshark wireshark 0.10.12
wireshark:wireshark wireshark 0.10.13
wireshark:wireshark wireshark 1.2
wireshark:wireshark wireshark 1.2.3
wireshark:wireshark wireshark 1.2.6
wireshark:wireshark wireshark 1.2.2
wireshark:wireshark wireshark 1.0.6
wireshark:wireshark wireshark 1.0.9
wireshark:wireshark wireshark 1.0.8
wireshark:wireshark wireshark 0.10.8
wireshark:wireshark wireshark 0.10.9

Related