logo
DATABASE RESOURCES PRICING ABOUT US

CVE-2009-4009

Description

Buffer overflow in PowerDNS Recursor before 3.1.7.2 allows remote attackers to cause a denial of service (daemon crash) or possibly execute arbitrary code via crafted packets.


Affected Software


CPE Name Name Version
powerdns:recursor powerdns recursor 2.9.18
powerdns:recursor powerdns recursor 2.9.17
powerdns:recursor powerdns recursor 2.9.16
powerdns:recursor powerdns recursor 2.8
powerdns:recursor powerdns recursor 2.9.15
powerdns:recursor powerdns recursor 3.1.2
powerdns:recursor powerdns recursor 3.1.4
powerdns:recursor powerdns recursor 3.1.3
powerdns:recursor powerdns recursor 3.1.7.1
powerdns:recursor powerdns recursor 3.1.7.2
powerdns:recursor powerdns recursor 3.0.1
powerdns:recursor powerdns recursor 3.0
powerdns:recursor powerdns recursor 3.1.7
powerdns:recursor powerdns recursor 2.0_rc1
powerdns:recursor powerdns recursor 3.1.1
powerdns:recursor powerdns recursor 3.1
powerdns:recursor powerdns recursor 3.1.5
powerdns:recursor powerdns recursor 3.1.6

Related