ID CVE-2009-2907
Type cve
Modified 2010-03-25T04:00:00


Multiple cross-site scripting (XSS) vulnerabilities in SpringSource tc Server 6.0.20.B and earlier, Application Management Suite (AMS) before 2.0.0.SR4, Hyperic HQ Open Source before 4.2.x, Hyperic HQ 4.0 Enterprise before, and Hyperic HQ 4.1 Enterprise before allow remote attackers to inject arbitrary web script or HTML via the description field and unspecified "input fields." Per:


* Hyperic HQ Open Source users should upgrade to Hyperic HQ 4.2.x
* Hyperic HQ 4.0 Enterprise users should upgrade to 4.2.x or
* Hyperic HQ 4.1 Enterprise users should upgrade to 4.2.x or
* Users of any earlier Enterprise version should upgrade to 4.2.x
* AMS users should upgrade to 2.0.0.SR4
* tc Server users should upgrade to AMS 2.0.0.SR4

To protect against this issue until systems have been upgraded and/or patches have been applied, system administrators should ensure untrusted users do not have the necessary privileges to create alerts.'