CVE-2009-0642

2009-02-20T06:47:00
ID CVE-2009-0642
Type cve
Reporter cve@mitre.org
Modified 2017-09-29T01:33:00

Description

ext/openssl/ossl_ocsp.c in Ruby 1.8 and 1.9 does not properly check the return value from the OCSP_basic_verify function, which might allow remote attackers to successfully present an invalid X.509 certificate, possibly involving a revoked certificate.