CVE-2008-3655

2008-08-13T01:41:00
ID CVE-2008-3655
Type cve
Reporter cve@mitre.org
Modified 2018-10-11T20:48:00

Description

Ruby 1.8.5 and earlier, 1.8.6 through 1.8.6-p286, 1.8.7 through 1.8.7-p71, and 1.9 through r18423 does not properly restrict access to critical variables and methods at various safe levels, which allows context-dependent attackers to bypass intended access restrictions via (1) untrace_var, (2) $PROGRAM_NAME, and (3) syslog at safe level 4, and (4) insecure methods at safe levels 1 through 3.